Cube Orange & PX4 stack issue

Hey to all, I stuck at my Cube Orange update to PX4.

I tried to upload latest stable release (v1.11.2 - cubepilot_cubeorange_default.px4) from here:

When I upgrade my Cube via MissionPlanner, upload is successful, however Cube hangs in bootloader and stack is never loaded and running.

When I try to upgrade to PX4 from QGC:

I’m getting this error:

I have two Cube Orange units here, both behaves the same.
Tried multiple QGC versions from 3.5.6 up to the latest and all have the same “error”.

Any ideas?

This guy seems to have the same problem:

I think this is just an inherent issue with PX4’s interaction with the orange cube. The way I fixed it was to flash first with Ardupilot through Mission Planner.. Once the proper drivers are installed, you can switch it over to PX4.

Thanks for the tip, but I made this swap back to the ArduPilot hunderd times now I think :smiley: So this will not solving the problem.
Also tried to uninstall COM drivers via W10 Device Manager, tried without them and then also tried to install back UAV driver and try all the round again. There seems to be deeper problem. Can you confirm that your PixHawk Cube Orange
is running PX4 latest without issues?

Sorry, I actually just returned my cube orange because it did not quite fit my needs (for a separate reason) so I can’t really check at this point, but I am completely certain that at least I was able to flash PX4 and arm. I would guess it’s a driver issue of some sort. Did you do the ‘driver clean’ step as suggested in the cube documentation? (see link above)

Cube Orange support requires a daily build. Did you try that?

Yes I did, but just for sure I tried now again. FW in the cube is ArduCopter 4.0.4 (if that has any impact).
Result is the same:

Can you move this to a QGC GitHub Issue and we can continue discussion there with ways to help debug

Issue posted. Thanks

I recently uploaded the px4 from the mission planner, using load custom firmware.

You can download a prebuilt binary for the cube orange here:

This is fixed now in Daily builds