Critical Reject Position Control

Hello All,

Hello, I am using Holybro Pixhawk 4 Mini, and Pixhawk 4 GPS Module, and the Pixhawk 4 Mini has ◦Accel/Gyro: ICM-20689◦Accel/Gyro: BMI055◦Magnetometer: IST8310
◦Barometer: MS5611.

I am till getting this error, how to solve this issue? Please help?

Thank You

Can you share a log please?

Good day, ive for the same issue with firmware version 1.9.2. I’ve disable all the internal compasses after ive done the mags listener and repeat again the calibration of all sensor.
This bug must be fix, with previous versions no problems

1 Like

@JulianOes @Dave84

Hello all, thank you for your support. Sorry for the delay in getting back to you all, I have been quite busy at work. Also I have to crash land the quad on Monday the 02 Dec 2019, and counting the cost of damage.

Dave I am running the same firmware version 1.9.2 on the flight controller. My PC’s both run Win7, and I am running QGround Control V3.5.5 on both. My R/C is Version: Development master f25149835 2019-04-26 18:59:47 +0530. R/C Make is Herelink Beta 1, yes it runs QGround Control as well.

Hardware is Holybro Pixhawk 4 mini with Holybro Pixhawk 4 M8N GPS Module from

What I have noticed so far on Monday the 02 Dec 2019:
I get the this error (Critical Reject position Control) when I arm the quad on my test bench, and I do not get this error if I place the quad on the ground in front of my house.
When this error is triggered I am unable to enter into Position Mode which I like to fly my quad with.
I was able to select Position by placing the Quad outside the home on the ground see the log stamped with 11:00 AM.

So I decided to take the quad to the field and test it after doing all the checks and putting the props at 2:00 PM the same day. On the field on initial boot-up, the same error prevented me flying. So I decided to move my position in the field and re-booted the flight controller. This time the error did not come up and I wanted arm the quad and arming was denied due to compass inconsistence. So I calibrated the compass in the field and re-booted the flight controller.

I was able to arm and choose Position Mode without any errors. So I used the auto take-off and the quad reached about 2m height, but it did yaw clock wise once and struggling to hold position.

I decided to bring the quad back and selected the RTL button and the quad rose to set 20m height and was struggling to land. So next I selected the Land button and the quad rose even further, and I tried to bring it down by lowering the throttle and I had no response.

The quad gained more height and was drifting away from me, so I had no option but to apply the Emergency stop, crashing the quad to the ground from around 40m high.

During the flight I also observed effects of vibration on the flight controller. I have had this vibration effect during my initial testing at home, as recommended I was using the vibration isolation pads provided with the kit during my initial test at home and the pads made the vibration effects worse and the motors were cutting out. So I placed the flight controller on double sided tape, and mounted it to the frame, and this stopped the vibration effects on my initial try at home. Is there a better way to isolate this vibration problem?

I am rebuilding the quad, I made the frame and it will take time to make the broken pieces and to replace the broken components. But my biggest concern is reliability of Pixhawk 4. I was using Cube Black and Here 2 by ProfiCNC, and encountered reliability issues with the cube black flight controller. But it did fly and held it course but temperamental at times, and also heavy for my application, hence I chose this current setup.

You guys are the experts so please analyse the logs I have provided and please assist me to fix the problem.

Sorry unable to upload the log’s, because when I down load the log from flight controller is in ULG extension, and I cannot upload this extension. So how to change to a format which can be up loaded to this post?

Thank You

Hello, @Ganesh!

You could upload your .ulg log to

If you see an oscillations or high-speed vibrations on your vehicle, you need to perform a PID tuning

And if your vehicle doesn’t goes down, you are to switch into Stabilize or Manual modes and this should help you to land it.

Try to tune your MPC_THR_HOVER and MPC_THR_MIN - your problems with landing could be because of them.

Hello all, @JulianOes @kpetrykin @Dave84. Thank you for your support, I have uploaded my log as per your request.

Please see the log dated 2019-12-16 Description: Critical Reject Position Control.

@kpetrykin thank you for your guidance, I am rebuilding my craft waiting on parts. Next time if I run into trouble I will switch in to Stabilize Mode as per your advice. I have used manual Mode before and found the throttle to be very sensitive, may be because the Trust - Weight ratio as per the eCalc is 5.2.
I am trying to build a endurance quad, so I have to reduce the weight as much as possible.

Your help will be very much appreciated. Thank You.

This makes sense as you probably have no GPS inside.

Sorry about having to crash land. Generally for the case where position control does not work as expected I suggest to switch back to altitude control and land manually. If position control does not work properly, then the chance is that also RTL won’t work well.

You need to paste the link here with the hash linking to your specific log. This link doesn’t help me find your log.

@JulianOes @kpetrykin @Dave84

Hello all, as per your request here is a link for my log. Please see below.

Thank You.

You seem to have crazy spikes on:

  • Thrust
  • Roll and pitch setpoint
  • Yaw rate setpoint
    and then it is also visible on the actuators power consumption, etc.

I’m not sure where it comes from but it looks very strange and rather worrying. I would check if all sensor and motor orientations are correct, and if attitude, heading, etc. looks correct relative to the world.