Convergence - Motors not work - using: Pixfalcon - Qgroundcontrol -Taranis X9D Tx- X8R Rx

#1

I am having problems getting Pixfalcon Mini flight controller to work in a Convergence RC model using QgroundControl (ver 3.5.3) with PX4 v1.9.0. This RC model is one of the selectable models supported by the software. I just bought the 3DR Pixhawk Mini with GPS, Power Module + Holybro Telemetry Radio Combo kit.

I have wired everything up and went successfully through all the calibration procedures (including ESC calibration) described in QgroundControl. Once the controller is armed using the external button, I have gotten all the servos to work on the Convergence RC model to work via my Taranis FrSky X9D transmitter and FrSky X8R receiver, and through the Pixfalcon controller. The controller is also able to auto stabilize the elevons. But I cannot get the Pixfalcon controller to control the electric motors using the Convergence ESCs. It should be noted that the motors work perfectly if I hook them up directly to the PWM connection on channel 1 of the receiver. I am using the 8 PWM breakout board provided in the kit, to generate the ESC signals, along with a ground which is tied to the battery ground. I also use the same breakout board to generate the servo signals, along with +5V and ground, generated by an external BEC.

I also tried installing Arduplane on my pixfalcon using Qgroundcontrol which also supports the Convergence vehicle. This configuration was able to operate both the servos and all 3 motors. This seems to indicate that my hardware is configured correctly and that it is working correctly. The problem seems to be with PX4 with the Convergence code. I am trying to load an older firmware version to see if it corrects the problem. Previous users have noted that this has fixed their problem.

nanthony21 commented on Jan 28, 2018

"I’m seeing this same issue on a pixracer.

Edit: I flashed Version 1.5.0 just to verify that it was an issue with firmware. Everything worked as expected in 1.5.0 so I flashed 1.7.3 again. Now the motors are working fine, the issue is fixed for me."

This is just a guess. has anybody else had this problem and got it to work?