Connection between AirSim and PX4 over the network

airsim = latest version 1.2.x / window 10
Unreal = v4.18
px4 = latest version 1.10.x / ubuntu 16.04

I did a lot of things to connect between airsim on window 10 and px4 on ubuntu 16.04 over network. Before, I tried to connect gazebo on ubuntu 16.04 and px4 on ubuntu 16.04 over the network and it work properly. I checked px4 - gazebo over network work well. So i think there is problem at AirSim or I’m making a mistake. but I have no idea what i’m doing wrong. please i need help…

first, I will show you px4-gazebo setting
i changed gazebo iris.sdf setting file to connect remote pc(px4).

i typed sumulator start like this
simulator start -u 14560

then, px4 is listening and gazebo is trying to connect

secondly, airsim-px4
I tried not only tcp connection but also udp connection.
In cast tcp connection, airsim linsten that you mentioned and px4 try to connecting.
Contrary, in case udp connection, i found px4 listen udp and airsim have to trying to connecting.
at this moment,
in px4, i typed
simulater start -u 14560
in airsim ,I thought I have to change airsim option
"UsingTcp": false, "UdpIp": "203.255.57.xx" "UdpPort": 14560"
px4 waiting udp well, but airsim get error like this.

why i don’t use tcp is that
px4 support mavlink(udp) connection over network
but doesn’t support simulator(tcp) connection over network.

i wonder airsim support only tcp for simulator connection??