Cannot load command parameter - vehicle_spawn_sdf.launch

Hey guys,

I am new to ROS. Actually I am facing the following problem:
I want to add multiple drones to gazebo. I figured out, I can do this with Firmware/launch/multi_uav_mavros_sitl.launch. This works great. I can see my iris drones in gazebo. However, I would like to add a camera to these drones which is quiet challenging for me.

I tried to add something to the iris_base.xacro file as described here
This works when I want to see the image in rviz, however I cannot see the image in qgroundcontrol what I would like to.

Then I tried to change the sdf file of iris, so that I am now having a camera on my iris and I can see the image in Qgroundcontrol which is nice. However, I cannot use the multi_uav_mavros_sitl.launch anymore. But I found the multi_uav_mavros_sitl_sdf.launch script which I thought would be the same just with using the sdf model.

At this step I am facing the problem that when I run the script I get:

NUC8i7BEH:~$ '/home/falke/start_multi_mavros_px4_sitl_sdf .sh' 
[0/4] Performing build step for 'sitl_gazebo'
ninja: no work to do.
[3/4] cd /home/falke/Firmware/build/px.../falke/Firmware/build/px4_sitl_default
Not running simulation (DONT_RUN is set).
GAZEBO_PLUGIN_PATH :/home/falke/Firmware/build/px4_sitl_default/build_gazebo:/home/falke/Firmware/build/px4_sitl_default/build_gazebo
GAZEBO_MODEL_PATH :/home/falke/Firmware/Tools/sitl_gazebo/models:/home/falke/Firmware/Tools/sitl_gazebo/models
LD_LIBRARY_PATH /home/falke/catkin_ws/devel/lib:/opt/ros/melodic/lib:/home/falke/Firmware/build/px4_sitl_default/build_gazebo:/home/falke/Firmware/build/px4_sitl_default/build_gazebo
... logging to /home/falke/.ros/log/9619be54-8094-11ea-9711-d0c6373825cf/roslaunch-falke-NUC8i7BEH-24428.log
Checking log directory for disk usage. This may take a while.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

RLException: while processing /home/falke/Firmware/launch/single_vehicle_spawn_sdf.launch:
Invalid <param> tag: Cannot load command parameter [model_description]: no such command [['xmlstarlet', 'ed', '-d', '//plugin[@name="mavlink_interface"]/mavlink_tcp_port', '-s', '//plugin[@name="mavlink_interface"]', '-t', 'elem', '-n', 'mavlink_tcp_port', '-v', '4560', '/home/falke/Firmware/Tools/sitl_gazebo/models/own/own.sdf']]. 

Param xml is <param command="$(arg cmd)" name="model_description"/>
The traceback for the exception was written to the log file

Does someone has an idea how to fix it? Really appreciate any kind of help.

I have not seen that I had to install xmlstarlet first like mentioned here

sudo apt install xmlstarlet

solved it.