Cannot get RC working in sitl

Hello, I’m trying to get RC Override working in the sitl for PX4.

I followed the tutorials:

The simulation is up and running. I can send setpoint commands, but I would also like to be able to control the drone via remote control or rc_override via Mavros.

Rc_override seems to be working fine when mavros is connected to a real Pixhawk. When connecting to the simulation however the simulation doesn’t react to it. The topic /mavros/rc/in however returns the /mavros/rc/override commands I send, so it looks like the data is received by PX4.

On the topic of connecting a real RC to the simulation, I didn’t seem to find any clear documentation. I tried connecting the RC via a pixhawk to QGroundControl. But then QGroundControl was just switching between the simulation data and Pixhawk data. (I.e. the orientation was constantly switching between the sim orientation and the Pixhawk orientation)

Any idea how I can get one or both rc methods working?

I just noticed in the log of the simulation:

WARN  [mavlink] mavlink for network on port 14540 is not running
Command 'mavlink' failed, returned 1

Could that be related?


MANUAL_CONTROL doesn’t work either. I tried all flight modes, but none seem to listen to the RC override.

The RC I got working now by directly connecting it to the computer via USB.