Caipi VTOL - pitch issues with Master firmware/plane goes level in MC mode

Hi there,

I am really lost right now.
I have gone ahead with building the Caipiroshka VTOL. I had a successful maiden hover earlier in my backyard with a master build of early April, and although it was only about 20 seconds due to constrained space everything was working fine. I have a short plot of the attitude vs setpoints here (scales offset to fit on one picture, of course) and you can see that it follows it pretty well - mostly fine I’d say (bit sluggish on yaw/pitch but that is due to the elevons I guess):

Now, I put it on the master build yesterday evening (I had the same issues with beta and master a few days ago as well). SInce then, I see the following behavior:

  • While holding the Caipi in my hand nose up and spinning up in MC mode, I can see that it is counteracting my movements with reasonable force and control inputs around yaw/pitch/roll are reflected correctly.
  • However, as soon as I take off from the ground, the plane will reproducibly pitch forward into level flight (nose forward) after a few seconds and is no longer controllable in a meaningful way.

When I look at the logs, it seems to me like the actual pitch is “inverted” and acts into the exact opposite direction as the setpoint goes.

Setup (none of these settings changed since the successful maiden hover):

  • Default Configuration of Caipi VTOL around a Pixracer
  • Compass and FC both mounted with Roll 90 / Yaw 90
  • AUX5 / AUX6 PWM outputs are inverted as the Servos would otherwise turn in the wrong direction
  • Circuit breaker for Airspeed Sensor set as I am waiting for Nick’s active I2C Hub for it to work correctly
  • AUX1 mapped to a receiver channel and the plane also reacts on switching it to fixed wing mode (on the bench)

Test changes done:

  • I tried VT_OPT_RECOV_EN = 1 with no noticeable effect
  • Sensors calibrated newly several times (Compass and artificial horizon shown correctly)

@LorenzMeier advised me to get in touch with you @tumbili whether you can reproduce the same issues on your reference platform with the current master? Any hints on what this could be due to?

Some logs:

Thanks for your help,
Daniel

Hi Daniel
Looking at your older logs I can see that the tracking of the pitch angle is not really satisfying.
I think hovering around in a garden where there is not much wind and when the pitch angle is relatively small will work fine. However, it gets difficult when there is wind from the front.

I think the elevons of the Caipiroshka are way too small. They have been designed to work well in level flight but not for hovering. I would therefore advise you to install larger elevons.
I’ve been working on a bigger tailsitter which is performing really well and I can give you the dimension of the elevon in relation to the body so that you get an idea of how big they should be.

Data refers to one elevon:
width: 43.5 cm <-> wing span: 92cm
height: 8 cm <-> chord length: 31 cm

So you can see that the elevon height is about 1/4 of the cord length of the wing.

Once you’ve done that feel free to contact me if there’s more issues. I can give you some advice on the optimal recovery stuff and transitions.

Regards,
Roman

Hi Roman,

ok, lets split this up in two parts (because my main concern was not what was visible in the earlier log):

  1. My observation that the behaviour was ok with an earlier master but now with the current master is broken: Have you been able to verify that your reference caipi still works as before? Or are you telling me it was purely coincidential that it worked in the garden with the older firmware but I have never even for 5 seconds been able to reproduce that with the new firmware in the field (no wind)? It feels to me like the plane is somehow transitioning to some weird state, it doesn’t even do the slightest attempt to stay nose up and it’s not like I am trying to do high speed maneuvers in strong wind? If it still works as previously at your end, it would be good to find out what the difference in our setups is.

  2. Your advice that the Caipirinha’s Elevon design is actually not that well suited: I get it that larger elevons give me larger control surface and hence would improve the behavior. But a bit of sluggishness is not my main concern now, unless you are telling me that the build that is suggested as a reference platform is actually not able to fly at all in MC mode with the standard Elevons?! That would be a bit, well, “surprising” to me to say the least… Have you ever been able to let your Caipi Tailsitter do automated position control for instance in MC mode? Once I am in the optimization phase I can of course look at modifying the Caipi Elevons to get better response, but right now I don’t trust that the FC is doing the right thing…

Can you please look again into the above? There are other users also looking into the Caipi Tailsitter build, and I think this info would be helpful for the community.

Thanks,
Daniel

Hello Daniel & Roman,

I am also testing with a Tailsitter VTOL now, same scheme as Caipiroshka, using Pixhawk, and have similar problems to solve:

  • after take off, still in hover/copter “stabilzed/main” mode, the plane pitches backwards (nose up/backward in my case) and tries to go in horizontal flight on its back.
  • manual “pitch” and “roll” commands stay locked to the orientation of the plane at the moment of powering up / initialising. That means, if you have made 90° yaw-turn, and than give manual “pitch”, it will be actually “roll” acc. the plane, but it will tilt the plane in the same direction as “pitch” would do at start position. It is like some “easy fly” mode for multicopters - do you know how this can be deactivated/activated?
  • I am not 100% sure, because it was a “hand held” test, but in “position control” mode, using GPS (no optical flow sensor), the corrections seem to work also in the opposite direction, bringing the Tailsitter away from the position it should stay on. This is something I can check and confirm/report about it, after the fix of the first two points.
  • “level horizon” is done in copter position (sitting on its tale), hope this is right.
  • “altitude control” works right and well

A friend of mine is working on the software, but I think this are PX4 Flight Stack settings - any ideas where to look?

Thanks for any help and advices!
Ivan

p.s. about the elevons size - mines are almost 30% of the chord and seem to work fine - a bit too big for fixed wing flight and a bit too small for hoovering.

Hi Daniel

I have not been able to test in the lab because I’m sick resting at home.
As soon as I’m back (maybe tomorrow) I can give it a test.
I was thinking to have read that when you hold it in the hand it seems to produce the correct moments.
Also I have seen that in your second attempt you tried it in a field where there could be wind.
It know that it can hover well in a room but it can go unstable from one sec to the other if there is just a bit of wind - that’s just the thing with these tailsitters.

I’ll let you know how my tests went.

Hi Roman,
thanks, get well soon! As soon as time permits I will revert to the old FW to double check in the other direction…
D.

Rolf over at the german fpv-treff forum has reported similar issues that @generator and myself reported. I haven’t been able to test the old master yet (will take several days before I can) but this really seems to confirm that something is really wrong about VTOL in the current master…

@Zimbo
Hi Daniel,
pitching backwards was a pure mechanical problem I had. After a crash repair, the elevons were not in the neutal position when the servos were in their middle position, so the plane was going steadily backwards. This might be also your problem with pitching…
regards,
Ivan

@generator Hi Ivan, thanks for the hint, yes, I will dig in a bit more once I am back home - elevon neutral trim should be OK (as in same as before) but I was using a slightly bigger battery so maybe the COG was just the “critical” bit further off and as @tumbili suggested the tuning probably can be improved as well. Plus the unexpected control behavior that currently is being worked on (#3620 and subsequent) might have led me to the wrong conclusions. Since you both have now reported that it is not a fundamental issue I am positive I will get into the air as well soon :slight_smile:
And Nick is sending my I2C splitter, so all pieces are coming together :thumbsup:
Will report…

Hi there,

wanted to finally give some feedback to @tumbili following my earlier posts. Have been quite busy recently but had a several successful tests of a current FW in my backyard with the Caipi VTOL and went for a bit more flying today in the field (unfortunately there was some wind). So: It works again Yeah :slight_smile:

To be honest, I am not sure whether at least part of this wasn’t actually on my side (trim of the Elevons as @generator also had seen on his VTOL). Anyways, after adjustments and with the new FW even today with the small gusts of wind I was able to maintain flight also out in the field, in contrast to not being able to take off at all even at no wind - so stabilization and control is back to normal (I also appiled @tumbili’s adjusted PID values that he had been using in his log attached to #4552).

But what you wrote about wind and the Caipi elevons is also quite true: I flew at 90 degrees to the wind direction and was able to keep it in the air quite well even then, but as soon as I (got) turned into the wind the plane was not capable of staying nose up even with massive manual intervention. Well, I already got some Balsa and as soon as time permits I’ll try to build larger elevons (hope the servos will be able to deal with the force).

Have a good weekend and thanks for your help,
Daniel