[Beginner] QGC Detected 0 Channels Issue

#1

Hi,

I’m a beginner at learning the PX4 and QGC, Any help would be great!

I have been having this issue for a few days now and I’m aware of the article that people have already asked. I followed:

I followed the steps Sparky002 gave many times and even tried slight adjustments to see if I messed up but still gave the error Detected 0 channels, needs 5 channels to operate.

On 9/11/2018 I had a PX4 geared up and ready to do its first flight. Come in Monday to upload the flight path which had no problem doing. Then I told it to run the path as a dry run inside (GPS was locked) and nothing happened. I couldn’t even switch to autopilot or manual flight on the radio which I was able to do on Friday. So I decided to get a fresh PX4 and set that up to see what I may have missed. Did all the Horizon calibrations and whatnot and when I came to the Radio setup I clicked ‘Calibrate’ and that’s when the Detected 0 channels, needs 5 channels to operate. I thought that was strange since I used the same telemetry from the PX4 that was geared in the airplane. When I set everything back up in the airplane it flagged the same issue.

The setup I have is a FrSky Taranis-Plus 16 channel, PX4 (FrSky X8R, Arm switch, 915MHz antenna). QGC v3.4.2.
X8R is plugged from the RSSI of itself to RCIN on the PX4.

Please let me know if I didn’t give enough information about the setup I have to help me out.

1 Like
#2

I figured out the issue. It was something super simple which is annoying. I had the plug that goes into the PX4 plugged in wrong. Once I flipped it around it recognized everything.

If anyone gets the same error try reversing the plugs because its very picky about how you plug it it.