AUX Feed-through to RC not working

Hi There,

I need your help to solve a issue that I’ve been struggling with for the past weeks. The problem essentially is that I cannot figure out how to make the aux feed-through working for my customize airframe (a tuned version of Quadrotor X Tailsitter). So far I’ve been using only I/O PWM OUT pins since I had 8 MAIN channels to be controlled, but now I want to add a couple of features that require the use of additional channels, so that I’m trying to configure the FMU PWM OUT.

Reading the documentation online about mixing and actuators I understood that if the modelname.aux.mix is not defined, the pass.aux.mix will be automatically loaded to make the aux reachable (using the control group 3) and then here’s my question: Why, if so it’s true, if I map the AUX1 for instance to a defined channel of my RC nothing happens?

I also checked on the inspector if inputs and outputs are matching and they do:

  • on the actuator_controls_3 topic I see the changes in pwm on the channel assigned to the aux1

-on actuator_outputs I don’t see any changes on the pwm, meaning that there’s no link between the command and the setpoint (?)

Any ideas?

P.S I’ve also tried to create my own ***.aux.mix using control group 3 following the documentation (in particular (3,5) and (3,6) for aux1 and aux2


but still no changes in actuator_outputs…

Thank you in advance,

Luca