Altitude flyaway - Help understanding what happened

I was testing a large quadrotor flying version 1.4.4 and using the INAV estimator. I was at about 15-20 ft in Position mode, and moving slowly in left and right. It suddenly shot up several hundred feet, well higher than the altitude geo-fence setting. Once it settled down and stopped climbing, I had a difficult time getting it back down in either position or altitude mode. Reducing throttle didn’t really settle down as it normally would. Prior to that I’ve done many flights in both position and altitude mode and it work excellent, holding position extremely well. I should also mention that I am using a LIDAR and px4FLOW unit. Looks like LogMuncher isn’t working at the moment to upload the log, but I’ll try and paste in a pic of the moment it occurred. It looks like the estimator suddenly thought the altitude was much lower than it was. It happened at about 54 seconds. Thanks ahead for the help! -Chris

Finally got plots and logs:


Strange results for Local Position (Z) and distance sensor. Any thoughts what could have happened? I’m afraid to fly the thing until I understand what happened.

Thanks for any help…

I took a stab at trying to understand what happened again. I still can’t make any sense for what happened. It looks like the estimator suddenly thought it was around 50-60 meters lower than it should be, so it tried to gain altitude back to where it thought it should be. LPOS.Z and GPOS.Z show this.

Decreasing throttle and trying autoland didn’t really get it back down to the ground very well. It eventually got there, but it was not behaving normally.

Does anyone have any thoughts about what would make the estimator in Z suddenly think it’s much lower than it really was?

Thanks again,


Sorry for the delay. Its mostly due to the use of INAV - we’re not supporting this estimator any more. Are you sure you are using it and not one of the other defaults?

Hi Lorenz,
Thanks for getting back to me. Yes, I was using LPE but didn’t have good luck trying to tune out position wobbles, so I tried INAV and it worked great – until the altitude flyaway. I looked thru the code and didn’t find anything obvious that could cause it, so I was concerned that it might be a problem with my vehicle rather than the code.

I’ve had many flights without an issue so the flyaway came as a big surprise.

I see now the default is EKF2 and have been planning to make the switch to the latest release (I’m still using 1.4.4) And to use switch to EKF2.

I was just hoping to understand what happened so I can correct whatever caused it… It’s an 18 lb commercial vehicle that is quite expensive, so for safety I want to make sure this doesn’t happen.



We switched to EKF2 particularly because of its inherently higher hardening against corner cases. Given that 1.4.4 is soon one year old you might reconsider your options.

I’ll switch over to the latest release and use EKF2. I imagine what happened is some corner case as you suggest.