Airspeed sensor SDP33 doesn't work

I had an old version of the PX4 flight stack and, after upgrading to version 1.9, the SDP33 is no longer recognized. There is no activity on the I2C bus.
I tried with Ardupilot Flight stack and it works
Are there any parameters to configure, to work with the SDP33?

Tried the v1.8.2 and it works. So there a problem on the 1.9.0

It’s possible that the appropriate driver is no longer included.

  • What model Pixhawk do you have?
  • When uploading the firmware, which one does it upload, px4_fmu-v2_default.px4 or px4_fmu-v3_default.px4?
  • Did you try uploading the Dev version?

Good luck.

Tried on Dropix V1.1 and Pixhawk V2. Same problem
I use the fmu_v2
Tried dev version and doesn’t work
Now it’s not a big problem because downgrade to 1.8.2 works, so I’m not stuck anymore to keep flying :wink:

Try uploading the fmu_v3 firmware. V2 probably doesn’t have the driver included.

Ah Thank you. It works with fmu_V3 :slightly_smiling_face:

No problem. Good to hear it.