0xfe 0x3e when trying to upload Firmware via Qgroundcontrol


I builded my code in a ubuntu virtual box and tried then to upload it via terminal. I always get rebooting messages continously and tried then to upload it via Qgroundcontrol. I receive then “Error: Sync: Send Command: Invalid sync response: 0xfe 0x3e” and after a few milliseconds the booting process of Pixhawk continues. So at least I know, that Pixhawk is recognized in my virtual machine.
On my windows 10 host it would be possible to upload my firmware, but since the builded firmware contains some symbolic links and references, my workaround to copy paste the files to a shared folder or USB would not work. Do you know, what I am missing with virtual box? I couldn’t find a solution using google :wink:

It sounds like you don’t have the USB id during the bootloader passed through to Virtualbox. If you can’t get that working then you could install QGC on the Windows host, and copy just the firmware out (.px4 file) to flash.

Okay, well I’ll setup a dual boot system then. this is probably much easier then. Thanks