0 channels detected

#1

hi, there are no channels detected , i’ve tried everything nothing is working i’m using Qx7 radio and pixhawk4 with latest 1.8, i was able to calibrate joystick,but not radio i’ve been at this for two days can anybody PLEASE HELP

#2

Hi @automike, which receiver are you using and on which port did you connect it to the PixHawk?

#3

HI, thank you for responding i have tried using R9 slim plus in plug it in ppm rc, as well as the dsm/sbus rc port. then i tried X8r s bus to dsm/sbus rc . my radio is Qx7 frsky also i tried both recievers using PPM encoder ppm port and dsm/sbus rc.I was able to calibrate the joystick

#4

I don’t fully understand. You can calibrate the joysticks but what’s not working then?

#5

I can not calibrate my radio,when i try i get message 0 channels detected so i can’t go any farther

#6

Okay, so, the steps are:

  • connect your SBUS receiver to the DSM/SBUS RC port of the PixHawk4
  • set your receiver to SBUS mode (depends on the receiver, for X8R you have to put the jumper on the right position, check the documentation of the manufacturer)
  • make sure the receiver is properly bound to your RC transmitter
  • start the calibration again in QGC, make sure the RC is not too close to the receiver

Try to reboot both the drone and the transmitter if not working.
You can also connect the receiver to a SBUS analyzer if needed.

Good luck!

#7

Thank you will give it a go and let you know

#8

Solution:

[…]followed your instructions and it worked. I was able to calibrate my radio; I believe my problem was I had my radio in mode D8 instead of s-bus also I had mode R9 instead of PPM.