Unable to start mission: Vehicle not changing to Mission flight mode

So I have a Pixhawk 2.1 Black, with telemetry and receiver etc. No GPS, but I have the PX4Flow optical flow sensor underneath. The sensor is definitely working, as the drone will perform auto takeoff and auto land, which it won’t do unless it knows its 3D position. I can also get reading of distances from sensor, within QGroundControl, pretty accurate I must say.

BUT, the drone refuses to go into mission mode for me to just perform a simple mission of takeoff, go to a waypoint, return and land. Does anyone know why this might be? Could it be a setting or something simple that I missed? Any help would be much appreciated.

1 Like

Were you able to resolve this query .

Is your transmitter on while starting the mission? I know due to some safety issues and some parameters the drone cannot start an autonomous mission while the transmitter is off.

If you have remote controller connected, set the flight mode into mission by using any of the toggle switch. From my understanding, the remote controller is the master.

Next in qgc, you also can slide to run the mission.

But if you have your remote as a master, or connected, you need to set it to mission flight mode. And make sure you have the system armed.

My transmitter is on yes, as I can perform auto takeoff and auto land, which before I had PX4Flow connected, I couldn’t do.

I tried where using the transimtter to set the flight controller to mission mode and it says reject auto mission. I tried it without motors being armed, and with motors being armed.

Do you have full GPS Lock?

Px4 flow support drone movement in horizontal axis? Are you sure?

No I don’t have full GPS lock, how would I get that with the PX4Flow?

I’m not certain on this, I have started to setup my Raspberry Pi with ultrasonic sensors to connect to the pixhawk to see if that changes anything

You will never be able to do a “mission” with out GPS. A mission is just a list of waypoints with the GPS coordinates.

1 Like

Others have flown UAVs autonomously indoors without GPS with QGroundControl so it must be achievable

@Luke_Connolly As @jimdgit has correctly pointed out, “Mission mode” is only supported when you have global position (GPS) since waypoints are defined as the gps coordnates.

However, you can still get position estimates using external source (e.g. Vision / optical flow) that you can use “Position mode”. This allows you to do indoor autonomous navigation in position flight modes or offboard mode.

In this case you need an external application safely guiding the vehicle through the “indoor” environment by sending control commands

1 Like

Yes, well you have to do some customization (which I don’t know what that would be) just to get into position mode as out of the box that requires GPS lock as well.

Ahh I see, thank you very much for clearing this up for me. It makes sense now, I can use a companion computer such as a Raspberry Pi to get distance metrics from sensors to safely navigate indoor environments. My setup does enter position mode as I have the optical flow sensor. Also thank you @jimdgit for your help.

lol remind me to never answer your questions again.