Unable to connect with QGC with Pixhawk Cube 2.1


I bought a Pixhawk Cube 2.1 with a GPS Here 2 and I am unable to connect with QGC. I tried different cables and different OS (Mac, Linux Windows) and it still don’t recognize it.

It work perfectly fine with another Pixhawk Cube 2.1. When I do Device Manager on Windows, it saw the pixhawk there is also the caracteristic sound (see picture attached - sorry it’s in french)

Hope you can help me



1 Like

Sounds like a hardware defect :confused:.

I’d suggest trying a daily build of QGC before assuming a hardware defect. It looks like the Cube is now shipping with it’s own bootloader.

1 Like

I tried QGC Daily build (on Linux and Windows) and nothing happened. I can connect with my other Pixhawk however…

I saw that the COM name is not the same for the two Pixhawk :

  • the one working -> PX4 FMU (COM4)
  • the one not recognized -> PRofiCNC CUBE F4 FMU (COM11)

It is possible to be an driver problem ?


Perhaps post a question on the Hex forum (www.cubepilot.org) and see if others have had this problem

1 Like

Ok I post on this forum :

(if you have the same problem)

Can you check if you are able to connect using Mission Planner? I had similar issue

Update. My problem was related to the Here2 GPS firmware and the new version of the Cube. I was able to connect using Mission Planner, but not QGC

I updated the bootloader on the Here2 and update the firmware. I’ve followed the instructions found here: https://docs.cubepilot.org/user-guides/here-2/here-2-instruction . Be aware of the possible label error with CAN 1 & 2 ports (this is mentioned)

Afterwards I switched the pin back to I2C and used the serial cable and connected the Here2 to the GPS 1 port on the pixhawk 2.1 module

Finally the problem was that the Pixhawk was sold without the firmware. The only way to flash it is to use Mission Planner and do the Initial setup. After, you can use the Pixhawk with QGC.

The procedure is there :