Throttle scaling for octocopter in stabilized mode?

Hi all, I’ve been troubleshooting an octocopter drone for a course I’m enrolled in, and after figuring out that some of the issues stemmed from PID auto-tune being enabled when it shouldn’t have been, I was able to have a somewhat successful flight after disabling auto-tuning: the drone took off without any issues and was able to stabilize itself in the air.

However, when I tried to lower it to the ground, the drone wasn’t getting any lower, and since it wasn’t very high up (and continued to drift away), I brought it down with the kill switch. After reviewing the documentation for Stabilized mode, I read about the MPC_THR_CURVE parameter for the throttle scaling, and noticed the part about how powerful vehicles might have a very low hover throttle, which can lead to more of the thrust being controlled by the top half of the throttle stick than the bottom. Is it safe to say this is why it didn’t seem to respond to my downward movement of the throttle stick, and if so, should I set this parameter to No Rescale?

Being honest, this drone has had a few minor crashes while I’ve tried to get it working again, so I’m hesitant to make any changes without really understanding them before trying to fly it again.

A link of your flight on is a good start to help people to define your issue :slight_smile:

1 Like

Sure thing, here’s the flight log.

This a log from an additional test in which the drone tipped on its side instead of taking off, but I think this could still be due to the MPC_THR_CURVE parameter being set to No Rescale since this is a pretty large octorotor drone.

This is one and maybe MPC_THR_HOVER might be the parameters to change. Not an expert of tuning so there is maybe something I missing in the log you sent. The documentation is pretty well detailed regarding this part here.