SDK SITL unit testing fail

Please excuse my ignorance, I am very newb. I am trying to install DronecodeSDK, and it seems to install without complaining (on a fresh VMWare with Kubuntu 18.04 LTS), but all of the unit tests fail… It does not matter which of the commands I run, I get the following type of output:

I am really quite unsure what to do… at some point I ran “make posix_sitl_default gazebo” in a separate console at the same time, and then the tests seemed happy for a little while, but then I was not able to reproduce the results.

If anyone has any tips or pointers, I would appreciate greatly!
A nerd in need.

PS: the logfiles generated by in home/DronecodeSDK/build/default/integration_tests generated the following:

PPS: The examples run smoothly though. There does not seem to be a problem there. It works both in jMavSim and in Gazebo.

Ok, thanks for the question. We have to distinguish between unit and integration tests. You are referring to the integration tests here because it’s together with the PX4 SITL simulation.
(The unit tests are make default run_unit_tests.)

It is known that not all of these tests pass right now. They need some fixing as well as be added to the continuous integration, otherwise they’ll always end up in a non-working state. It’s one of the tasks todo, I just created an issue, so this is tracked properly:
Contributions or fixings to make them work are very welcome.

1 Like