Reverse gyro behavior in stabilize mode - ails and elev go wrong way

#1

setup:
px4 1.8.2 stable
QGC 3.5.0
pixhack v5 installed 180deg yaw
gps installed 180deg yaw
normal plane AETR
qgroundcontrol sensors calibrated at 180yaw rotation.
artificial horizon shows correctly.
no mixing of AETR channels in radio.
.
manual mode works fine.
stabilize mode" rc inputs correct movement, but gyro for ailerons and elevator go wrong way.
.
crashed with tell-tale invert-and-dive as soon as stabilize mode (from manual mode) activated. my fault - forgot to check stab mode operation before flight.
.
previous day: had same behavior but caught it before flight. tried reversing servos in radio - no effect. changed rotation of FC in QGC settings and disabled mag0(or mag1?) because of conflicting mag messages. flew correctly, but replay showed plane suddenly switching orientation after takeoff and flying in reverse. So i recalibrated with correct FC orientation (180deg yaw) and messages went away. got distracted and forgot to check gyro operation before next day’s flight.
.
why is the calibration not setting this up correctly? what is the fix?
.
btw, the 3d flight recreation tool on the flight log page shows my aileron/elevator stick going the wrong way.

#2

Any suggestions? I can’t seem to figure this out. If I try and invert the gyro scale factor in sensor calibration, the initialization fails for the gyros cal and the artificial horizon is backwards (even though surfaces move correct direction).
.

#3

Did you try to reverse in PWM_MAIN_REV1 and REV2?

Good luck.

#4

@rollys… yep…found that this morn and it fixed it. that was the solution. I didn’t try that before because i thought it would reverse direction for ALL servo behavior - as in RC transmitter control of servos. turns out it doesn’t mess with the RC transmitter direction - just the Flight Controller originated PWM’s.
.
if this was documented in setups somehwere, i didnt see it. I still think that this should have been taken care of by the calibration routines with the rotation settings. that would be my suggestion for improvement.
.
btw, funny thing… i also reversed my throttle while i was doing that, and got quite a suprise when the plane went full throttle on the runway! oops.

#5

Glad that resolved it.

Good luck.