Problem with pid tuning on angular rate loop in arco mode

Hi everyone! Today,I am tuning my drone(x frame quadcopter) in acro mode.No matter how bigger the p of pitch axis I increase,it doesn’t go to oscillate.Even I try to increase it to 2000,but it doesn’t start to oscillate.Is there any one who has experience this problem.

Which parameter exactly are you increasing there?

I increase mc_rate_pitch_p.

If yes, that would be correct, not sure why you didn’t see an effect.

yes.maybe my plane is too big

I would doubt it. Feel free to upload a log and somebody can have a closer look.

1 Like