Please help. ..Pixhawk 2.4.8 load firmware error!

Hi Guys,
I download bootloader px4io_bl.bin and px4fmuv2_bl, and flash correct to my pixhawk without error.
but when upload firmware ArduCopter-v2.px4 but have error.
I don’t know so much about Python. please help me.
Note : My pixhawk broken and damage usb port, just upload via Jtag and uart.)


Regard
Reed Noel

@gregswf, @ksschwabe please help.
Thanks
Reed

It looks like your .px4 file doesn’t have a field called “image_maxsize”.

I have never worked with the ArduPilot firmware, so I don’t know whether this should work under the new Px4 system.

Please try and upload the standard px4fmu-v2_default.px4 firmware from Px4 (https://github.com/PX4/Firmware/releases/tag/v1.7.0), and see whether that gives you an error or not.

Are you using the latest version of the Px4 uploader (latest git commit)?

@ksschwabe,
Thanks for your feedback.
let my try with Px4 default.
I looking for new firmware, because, Suddenly my pixhawk can’t arm without notice in Mission Plan/Qgroundcontrol.
Rgs
Reed

Dear @ksschwabe,
I using python ver 3.6 and also hapend error with last python.
2 led power is light and 2 led of B/E blink , that mean already in bootloader mode, is this right ?
https://youtu.be/3mylQZh_s7I
when I upload firmware of your link, happend other error:


Please help me with many thanks.
Regard
Reed

There is a problem with loading your firmware file. I don’t know why that fails if it worked earlier with your other ArduPilot .px4 file. Does it still work with your previous ArduPilot .px4 file?

When you run the command, you should see Loaded firmware for 9,0, size: 1030589 bytes, waiting for the bootloader..., irrespective of whether you are connected to your board or not.

Please note that I only work in Ubuntu when developing for the Px4 boards, so your problem could be related to using Windows and different versions of Python than what is supported by the Px4 community.

Thanks for quicky reply.
Let me try install untubu in my laptop, I hope you help me fix my pixhawk.
I search on internet, untubu can install inside win10.
Before, with your support, I upload bootloader, and upload firmware, everything ok.
please show me, the led notice about already in bootloader ?
Reed

@ksschwabe,
I install untubu on my macbook.
May you give me the link , that manual upload bootloader and firmware of pixhawk1.
Thanks
Reed

I don’t understand what you are asking me.

I mean, my macbook install win10, so now i addition untubu.
Please show me how to upload boodloader and firmware on pixhawk.

You should already have the bootloader on your Pixhawk.

Have you set up the Px4 Firmware environment in Ubuntu? If yes then run python <path_to_px4_tools>/px_uploader.py --port <port> <.px4 file>, e.g. python px_uploader.py --port /dev/ttyUSB0 ~/Desktop/px4fmu-v2_default.px4

If it is successful you should get an output like this:

k@K-Desktop:~/Px4/Firmware/Tools$ python px_uploader.py --port /dev/ttyUSB0 ~/Desktop/px4fmu-v2_default.px4 
Loaded firmware for 9,0, size: 1030589 bytes, waiting for the bootloader...
If the board does not respond within 1-2 seconds, unplug and re-plug the USB connector.
Attempting reboot on /dev/ttyUSB0 with baudrate=57600...
If the board does not respond, unplug and re-plug the USB connector.

Note: you will have to check what port in Ubuntu you are using to upload upload the firmware to your board. If using the USB port on your board, it is probably /dev/ttyACM0, but if you are using an FTDI cable, then it is probably /dev/ttyUSB0 - you can check what port it is by plugging in your FTDI cable and running dmeg. The output will be something like this:

[102975.013661] ftdi_sio ttyUSB0: FTDI USB Serial Device converter now disconnected from ttyUSB0
[102975.013671] ftdi_sio 3-8:1.0: device disconnected
[102976.022698] usb 3-8: new full-speed USB device number 60 using xhci_hcd
[102976.155673] usb 3-8: New USB device found, idVendor=0403, idProduct=6001
[102976.155675] usb 3-8: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[102976.155677] usb 3-8: Product: TTL232R-3V3
[102976.155678] usb 3-8: Manufacturer: FTDI
[102976.155678] usb 3-8: SerialNumber: FTFMGFDF
[102976.157811] ftdi_sio 3-8:1.0: FTDI USB Serial Device converter detected
[102976.157843] usb 3-8: Detected FT232RL
[102976.157968] usb 3-8: FTDI USB Serial Device converter now attached to ttyUSB0

This shows you that it the FTDI cable is connected to /dev/ttyUSB0.