Pixhawk change mode failed

Hi, guys!
We had met these similar problems in these days and get in trouble with changing mode failed.
First, we used remote control to set off the quadcopter in Stablize mode, then we tried to change the flight mode to Auto, Loiter and Guided mode, but these attempt all failed.
Is it due to the EKF becoming red?
Have you ever meet these cases? Can you give me some solutions?

Red EKF maybe the cause.

Sometimes 3D fix is not enough because low number of locked GPS sats or HDOP too high.If you are using Ardupilot firmware.

Maybe you should waiting for a long time for more locked sats(at least more than 7, or batter more than 12).

Or you can just disable EKF check in mission planner.It might be work.

And,if you are using a indoor GPS signal repeater,it might be make GPS get lower number sats too.

I solved it by changing the parameters of EK2. I didn’t enable the EK2_ENABLE, so I turned it from 0 to 1. And I set EK2_GPS_TYPE at 2. Then I surprisingly found that the EKF turn white.
Thank you anyway. :smiley: