PixFalcon QGroundControl Radio issue

Hello everyone,

First of all I’m using:

  • PixFalcon
  • Receiver : FUTABA R7014
  • Transmitter : FUTABA T18SZ (mode 1)
  • QGroundControl with fixed wing model (latest firmware updated from QGC)

Every sensor calibration are OK (Not the airspeed one but I don’t have one and it shouldn’t be the issue)

When trying to calibrate the radio, I’m able to get a very low signal while moving the transmitter left throttle (in mode 1), but nothing when I leave it idle. That way I’m able to start the calibration, but with the low signal and the numerous losses of signal, the calibration is hard to make, and basically impossible without moving the left throttle, inducing errors.

I tried to power up my receptor with an external source.
I tried to switch between SBUS and SBUS2
I tried to radio control servo without the pixfalcon and it’s OK

If you have any ideas on what I could do to fix it, I’d be really grateful!



It’s most likely a telemetry noise issue as opposed to an RC transmit/receive issue. The RC data for calibration comes to QGC over telemetry connection. You can try calibrating you RC while you are connected over USB to the board instead of a radio. But you still likely have a possible bad telemetry noise issue.

I got the low signal when the left stick is on position 79 in elevation.
Do you think it may come from the controller?

I changed the receiver for a FrSKY TFR8SB, binded it with my FUTABA controller and it’s working like a charm!
I believe that there is a compatibility issue between FUTABA receivers and pixhawk 4 / pixfalcon / maybe others.
If anyone knows a way to contact the devs so they can fix this in the next firmware release (it seems like it is a firmware issue coming from sbus.c).

Thanks for the help!