No hearbeat to companion computer via ftdi

I am a beginner with px4 and I am trying to connect a companion computer (my laptop for testing purposes) to a pixhawk 4 TELEM2 port.
I was following the manual using a FTDI with a JST connector (cutting the 5V wire) but I cannot get a heartbeat on /dev/ttyUSB0 using the testscript QGroundControl also fails to connect with disconnected link "serial" as it contained no MAVLink data.

When I run screen /dev/ttyUSB0 I see something happening but I can’t figure if I wired something wrong or if I did the configuration wrong. I used the table from the config.

I set the configs for MAV_1 same as for MAV_0 but I tried different configurations as well.

When I print mavlink status over the working telemetry radio connection I get the following output:

I think instance #2 must be my serial connection and there is a rate on tx but none on rx so maybe this is wrong? I have a instance #0 as well so apparently they don’t match with the instances of the MAV_X_ settings…

Does anyone see what’s wrong in this setup? Any help would be greatly appreciated!

The problem was the wrong baudrate on TELEM2, which differs from the one at TELEM1 per default. Had to set SER_TEL2_BAUD to 57600 8N1, after that it worked flawlessly.

1 Like