mRo X2.1 not responding after SD card formatting

Hi everyone,

I recently formatted the SD card of my mRo x2.1 autopilot, and now my hardware is not responding via USB. QGC does not recognize it (like if the USB cable was not plugged in), nor can I upload code using make auav_x2.1 upload, it stops at waiting for the bootloader... forever.

I tried to update the bootloader as the x2.1 is known to have an issue with it. But it didn’t solved it.

It worked fine before I format the SD card, so I am wondering if the SD card needs a special type of format: FAT32 ? size of the blocks ? Is the autopilot suppose to be able to connect even without an SD card ?

any idea ?

I am however able to get data from the serial debug port (U7Tx on the x2.1).

[boot] Fault Log info File No 4 Length 3177 flags:0x01 state:1
[boot] Fault Log is Armed
sercon: Registering CDC/ACM serial driver
sercon: Successfully registered the CDC/ACM serial driver
HW arch: AUAV_X21
FW git-hash: 7a39954bbf08a8b860cf33d83cebb910d36f5220
FW version: 1.10.1 0 (17432832)
FW git-branch: release/1.10
OS: NuttX
OS version: Release 7.29.0 (119341311)
OS git-hash: 427238133be2b0ecd068a11e886ee8fdbc31f6dc
Build datetime: Apr 17 2020 12:44:37
Build uri: localhost
Toolchain: GNU GCC, 7.2.1 20170904 (release) [ARM/embedded-7-branch revision 255204]
PX4GUID: 000100000000363533353336510900290021
MCU: STM32F42x, rev. 3
[hardfault_log] Fault Log is Armed
INFO  [param] selected parameter default file /fs/mtd_params
INFO  [tune_control] Publishing standard tune 1
Board defaults: /etc/init.d/rc.board_defaults
WARN  [rgbled] no RGB led on bus #1
nsh: rgbled_ncp5623c: command not found
nsh: rgbled_pwm: command not found
Board extras: /etc/init.d/rc.board_mavlink
INFO  [mavlink] mode: Config, data rate: 800000 B/s on /dev/ttyACM0 @ 57600B
Starting MAVLink on /dev/ttyS1
INFO  [mavlink] mode: Normal, data rate: 1200 B/s on /dev/ttyS1 @ 57600B
INFO  [init] Mixer: /etc/mixers/speeder.main.mix on /dev/pwm_output0
INFO  [init] Mixer: /etc/mixers/pass.aux.mix appended to /dev/pwm_output0
INFO  [logger] logger started (mode=all)

NuttShell (NSH)
nsh> INFO  [ecl/EKF] EKF aligned, (pressure height, IMU buf: 22, OBS buf: 14)
INFO  [ecl/EKF] EKF GPS checks passed (WGS-84 origin set)
INFO  [ecl/EKF] EKF commencing GPS fusion

it was working the day after, I did not change anything…