Moveit iris.xacro problem


I tried the example: MAVROS Offboard control example and everything worked perfectly. After that I tried to install Moveit! I initialized Moveit Setup Assistant and tried to load iris.xacro model from path : “~/src/Firmware/Tools/sitl_gazebo/models/rotors_description/urdf/iris.xacro”, but I got this message: Running xacro failed. The terminal error output was “Undefined substitution argument rotors_description_dir None when processing file: /home/john/src/Firmware/Tools/sitl_gazebo/models/rotors_description/urdf/iris.xacro”

What can i do in order to use iris model with moveit ?

1 Like

Hello !
Did you get it to work ? I am stuck at the same point. However I am trying this with Rviz.

Replace in xacro arguments: “–inorder” with “–inorder rotors_description_dir:=… visual_material:=green”

Yes @sfeger ! Thanks much ! I did that. Made a urdf file from iris.xacro. Now I want to use it in rviz. I am trying to figure that out.

@sfeger , were you able to view the iris model in rviz ? I have been trying to do that since 3-4 days with no success. I installed gazebo_ros and was also able to upload iris.xacro in move it and get the iris_config files. Any help is appreciated.

Unfortunately, I will be out of computer for the next 20 days and I didn’t try to run it with rviz. Try that example of motion planning with moveit with other config files of a robot, it may help to run iris example:

I think that the problem is related with the fact that iris relevant files are not compiled with catkin build in order to initialize them with roslaunch, that’s why you can’t run the simulation with config files of iris, because they are not built in with ROS.

I believe that the solution can be found using ROS wrappers: Launching Gazebo with ROS Wrappers (

I tried the moveit tutorials. No luck with that. I will try Gazebo with ROS wrappers and keep you posted here. Thank you very much @sfeger for helping me with this!