Motor command not supported


I’m trying to test my motors in QGroundControl but I’m getting a ‘Motor command not supported’ error message when trying turn up the sliders (see screenshot).

My flight controller is a 3DR Pixhawk Mini and the uploaded firmware is PX4 v1.10 stable.

I tried to test the motors through the Mavlink Console (motor_test command) but this is not working : no error message but the motors just won’t spin. (see second screenshot)

All the other calibrations went well (except for the RC calibration - I’m not using an RC for now) including the ESC calibration. By the way the motors spin normally when arming the quad so I feel like this is more of a software/firmware issue. I tried using QGC on other computer but I’m getting the same error.

Does anyone have any idea on why this happens and/or how I could try to fix it ?


1 Like

Hi Ced

This got only added after 1.10, so currently you need to flash master of PX4.

Yep, it works now. Thanks !

How does one obtain the Master of PX4…? I have the same problem… yet, I believe the wiki says you can’t fly w/the Master because it’s not thoroughly tested…?

1 Like