Mission failure into Manual mode

Hello,

I had a crash that seems due to mission mode failure.

My setup:

  • 210mm quad, config as Generic racer 250.
  • AirMind MindRacer flight controller v1.2, running EKF2
  • ublox M8N GPS
  • FrSky XM+ receiver / FrSky Taranis X9D plus

I am using a relatively earlier version of PX4 version v1.6.5.

Before the crash, this problem actually popped up once. I was flying a planned mission as in below figure:

Everything started very smooth, until when almost reached waypoint #14 GCS suddenly alarms
“manual flight mode”. This should not happen as neither GCS or RC are trying to change any states. I can see on GCS screen that the quad starting to drift away from planned path. I tried to maintain altitude and adjust heading for a while and then I decided to trigger RTL to bring it back. The quad landed safely in the end.

However I got no more luck when this problem happened again for 2nd time in the next flight, in still the same location, and almost the same path. The GCS alarmed once again that the quad abort to “manual flight mode”, and this time as my RC throttle is on the minimum position(my bad), it directly fall into the lake.

Unfortunately I did not download the log before the quad crash, so I can not provide anything here for analysis. I just would like to clarify some points:

  1. If for some reason that Mission mode fail, for example GPS lost fix, or mission data corrupted, will it by any chance that it may bail out into Manual mode? Intuitively should not it set itself into hold or pos or alt control mode?
  2. Another behavior I noticed is though not fatal, but the quad seems quite “hesitate” when make a turning around at some waypoints. It may hang there for quite long time before it “decided” to heading to next waypoints. and some rare cases that I also observed, that when it needs to make a turn around to next waypoint, the quad seems can “fail” to make the turn and it keeps trying for several times before it succeeds adjust it heading. What could be the possible cause?

thank you.