Missing images in calibration screen of QGC

#1

Hi,

Today we found a quite interesting error in QGC.

Our setup is not simple. Therefore, there is drawing.

Booth computers use Ubuntu and there are connected directly only through one switch. (Without other network devices)

Problem

We do not use this setup for the first time. And this error happened for us for the first time. We were calibration before the flight. So I opened QGC, sensors panel. I have clicked on accel calibration. And pictures of aircraft orientation did not show up. I was quite confused about that.

There were only a progress bar and a screen with text output. That text shows some status of calibration. When the calibration was complete, the green progress bar was still loading.

I have tried few times to restart ros and mavros on PC1, restart QGC on PC2, restart aircraft. I have also tried different QGC version… Nothing of this helped.

Then I solved it by connecting the receiver directly to PC2 through USB and restarting QGC.

So, There are some functional differences in communication through UDP and USB? Is there any way to hide/show calibration helpers?

#2

Interesting. My guess is that one of the messages that QGC needs to know that the calibration is in progress gets lost somehow or is not forwarded by MAVROS. Were you able to find out if the problem happens due to using the SiK radios or due to using MAVROS?

#3

I have also observed, that latency of mavros UDP is quite variable. From some hundreds of milliseconds (I can’t it determinate well)
to seconds. Ping between computers in booth direction is always around 1ms.

I think it is caused by MAVROS or some software part of this way. But I don’t know how to determine it accurately.

Is possible to do something similar (streaming MAVLINK through UDP) with dronecode?

#4

Have you tried using the SIK radios without MAVROS?

And have you tried using MAVROS without SIK radios? You need to rule either one out, I think.

#5

No. I haven’t tried MAVROS without SiK radio. I’ll try it next weekend. My next idea is to try to use 1Gb switch (instead of 100Mb) or connect computers directly with ethernet FTP cable.

Also, we have trayed to use mavrouter (on your advice), but it is not flexible enough for us.

SiK without MAVROS works properly. Thanks for your ideas.