Mavlink Inspector works but no vehicle connection via USB

Hi, for a while now i tried to set up a mavlink router system.The Holybros s500 PX4 i work with spontaniualsy stopped working.All i did was changing some parameters in the MAV Tab and QGC only shows me the incomming stream via MAV Link Inspector but not a connected Vehicle. (Windows connects sound ,disconnect sound, connect sound)

So far i tried:
MP connection ,failed
Another USB Cable,failed
Another USB Port, failed
Diffrent PC , failed
Reinstalling QGC ,failed

An this happend twice. I stopped working with the first PX4 and used another one but after a day the same failure accured. I can buy new ones but i have the slight feeling that this happens again.

You say that you changed params and now it doesn’t work? In that case I would try to reset the parmams and try if that fixes it. I think there is a “reset params” button in QGC.

Sadly there is no option for this because there is no vehicle connecting. I only changed mavlink parameters.

Have you tried to connect with a daily (newer) version of QGC?

I reinstalled a older version and it worked again. Then i uploaded the newest one and it worked also.
Thanks for the support.

1 Like