MAVGAnalysis: In-Flight Analysis Tool for PX4

I’d like to announce some major improvements of MAVGAnalysis:

  • Stability and performance fixes
  • Import of PX4Log-Files
  • Display of device parameters
  • Storage and retrieval of acquired data
  • Improved replay
  • Direct import of latest PX4Log via WiFi (MAVLink based)

It is available at https://github.com/ecmnet/MAVGCL

1 Like

Looks very nice! Would like to try it out on Ubuntu 14.04. What is the easiest way to get it up and running?

1 Like

Should not be different as described. Be sure you have Java 8 installed.

I tried opening a px4log generated by a 4 day old build of the PX4 master, but all I get on my console is (over and over) and no data is display in the gui (demo data still showing):

FLOW.RawX not found in file
FLOW.RawY not found in file
FLOW.Qlty not found in file
FLOW.Dist not found in file
GPS.HDOP not found in file
899 entries read. Timespan is 44.95 sec````

Any idea why?

Hi,

those messages are related to the log-parser and mean, that the the key figures mentioned, are not available in the log (unfortunately, this message is printed with each time frame). This does not stop the parser to read data. In your case 899 entries are read covering 44.95 seconds. To check, whether data is available, just e.g. select accelerometer data in the time-graph. A graph should pop up.

Again some new features of MAVGAnalysis:

  • Tuning widget added
  • FrSky Taranis USB supported in SITL
  • Attitude key figures added
  • Performance and style enhancements

It is available at https://github.com/ecmnet/MAVGCL

Screenshot

Binaries now available for Windows, OS X and Linux.
Release 0.36 available now.

Pre-release 0.4 is now available at: Releases · ecmnet/MAVGCL · GitHub.

Version 0.49 (Pre-Release 0.5) has basic support for MAVLinkShell (NuttShell via MAVLink).

Hello
I’ve just tried to use MAVGAnalysis, latest version, downloaded binary.
I have installed MAVProxy to send the Mavlink messages from the Pixhawk (connected with USB) to UDP.
Have tested MAVProxy with QGroundControl and works fine.
Now when I launch MAVGAnalysis it appears to be recevingdata, but the screen flickers and nothing is displayed. The flickering is caused by the details tab appearing and disappearing constantly.

I experienced the same behaviour in both Linux (Ubuntu 14 LTS) and MacOS El Capitan.

Any tips on what could bet going on?
Thanks

This is the screen output on Mac

$ java -jar MAVGAnalysis.jar
UDP Controller loaded (192.168.1.88:14550)
MAVMSP parser: 32 MAVLink messagetypes registered
MAVLinkReader 2 started
Vehicle (NIO2): BindPort=14550 PeerPort=14550 BufferSize: 16384
Logging to: /Users/ealdaz/Dropbox/_edu/Personal/16-Free/Projects/SpinDrone/MAVGAnalysis/MAVGCL/msplog_2017-03-07_113134
States initialized
Built-In model definition (version 0.6) with 147 keyfigures 
CombinedConverter started
Found the following ports:
ParameterFactMetaData Version: 1.14
...................Reading parameters...
.Reading parameters...
.Reading parameters...
.Reading parameters...
.Reading parameters...
.Reading parameters...
Mar 07, 2017 11:31:40 AM com.sun.javafx.scene.control.skin.VirtualFlow addTrailingCells
INFO: index exceeds maxCellCount. Check size calculations for class com.comino.flight.widgets.info.InfoWidget$1
.Reading parameters...
.Reading parameters...
.Reading parameters...
.Reading parameters...

I have also compiled from source and have the same behaviour.

Have also tried connecting thru serial as indicated in: https://github.com/ecmnet/MAVGCL

For USB connected devices start withjava -jar MAVGAnalysis.jar --SERIAL=true)

However not sure if this is really supported as further down the page it says:

Limitations:

Limited to one device (MAVLink-ID ‘1’)
Currently does not support USB or any serial connection (should be easy to add, so feel free to implement it). Note: Serial via radio might be too slow.

In any case it seems to connect if I run as sudo ( but not necessary when using QGroundControl)

/dev/tty.usbmodem1
2017-03-07 11:55:24.286 - /dev/tty.usbmodem1 - Measurement rate set at 1 Hz
2017-03-07 11:55:24.286 - /dev/tty.usbmodem1 - NMEA GGA messages enabled
Connection on /dev/tty.usbmodem1 established
StartUp RTCM3 base...with SVIN accuracy: 3.0m
ParameterFactMetaData Version: 1.14
...............................  ```

If I don't I get a port busy message:

```Found the following ports:
/dev/tty.usbmodem1
2017-03-07 11:54:58.026 - /dev/tty.usbmodem1 - Measurement rate set at 1 Hz
2017-03-07 11:54:58.026 - /dev/tty.usbmodem1 - NMEA GGA messages enabled
Connection on /dev/tty.usbmodem1 established
StartUp RTCM3 base...with SVIN accuracy: 3.5m
ParameterFactMetaData Version: 1.14
..................Port name - /dev/tty.usbmodem1; Method name - openPort(); Exception type - Port busy.
Port name - /dev/tty.usbmodem1; Method name - openPort(); Exception type - Port busy.
Port name - /dev/tty.usbmodem1; Method name - openPort(); Exception type - Port busy.```

Thx

I should complete by saying that when connected thru USB I don’t get the flicker but I don’t get data either.

I have chosen data from the dropdown, but nothing appears.

Is there some start button somewhere that needs to be clicked?