JSBSim SITL Error [simulator mavlink] # of sim accel

I can run jMAVSim SITL with QGC, but JSBSim SITL does not connect to QGroundControl and displays this error repetitively: “ERROR [simulator mavlink] Number of simulated accelerometer 176 out of range. Max: 3”

The number is not always 176, but its always much larger than 3.

In the Ubuntu (Focal Fossa) terminal I use: make HEADLESS=1 px4_sitl jsbsim_rascal
Let me know if I should provide more information. Thank you

Hi, I have the exact same problem as you also running jsbsim on Ubuntu Focal Fossa. The error doesn’t always appear either, if I try to make again with the same arguments it will sometimes build correctly.

1 Like

More info:
I installed JSBSim-devel_1.1.0-102.focal.amd64.deb
It installed to /usr/include/JSBSim

I followed the instructions from JSBSim Simulation | PX4 User Guide

I had previously attempted PX4/JSBSim SITL with Ubuntu Bionic Beaver. I saw the same error with the Beaver and as well.
I tried JSBSim-devel_1.2.0.dev1-946.focal.amd64.deb with Focal Fossa, same error.

Did any of you guys find a solution to this error message? I’m running JSBSim SITL for fixed wing in flightgear and receive a similar message. Strangely for me it does not seem to hinder the sim in any way (missions run fine etc.).