Issue with data review from SD card

Hello everyone. Me and my coleagues wanted to log data from pixhawk to an SD card using “logger on” command in Mission Planner. After the logging we wanted to download data to computer using “Download data using MavLink” function in MP.
we have binary log file with, for example 5000 kB, but after we convert it to .log or to matlab file it has only 1-3 kB and has no value… When we want to review log in MP it shows the prompt that it can not be visualizes because it has no FMT messages… Can ANYBODY pleas help where is the problem ??

we tried different types of SD cards, formatting them, reinstalling new pure firmware and nothing works… i wanted to find log_bitmask, as mentioned in some discussions but in Standard Params i have no options to check.

The help would be very much appreciated, our work is stuck because of this logging issue. Thanks in advance to anyone answering

For assistance with ArduPilot it’s best to ask at

Thank you for answer.

We are using PIxhawk PX4 Flight stack. So i guessed it belongs here. Do you know what could be the problem ?

Whilst the mavlink tlog format is the same, PX4 doesn’t generate the same onboard log format as Ardupilot: the FMT messages MissionPlanner is looking for are components of the ArduPilot binary log. Without them Missionplanner doesn’t know how to interpret the log.

So are you suggesting that we should use ardupilot software instead of PX4 in order to better visualize it in MP ? I uploaded PX4 firmware via QGC.
I am asking because when we downloaded data long time ago (with at that time built firmware), the data (binary log) could be converted easily and it worked well. Now we do not know why it doesn’t work and we can not use neither binary log, neither tlog or any other format when we convert it to matlab file in mission planner.

We use logger in MP to log data but after downloading it and converting it to matlab file it has only few kB, so it is not possible to use it. All we need is position of flaps on our VTOL during flight for further analysis.

Which firmware is entirely up to you: I’m not going to suggest one over the other.
There are a number of visualisation tools for PX4 (QGroundControl, flightplot, plotjuggler, mavgcl as examples).

I am using PX4 Flight Stack because we have PIxhawk. It is correct right ?

We are just having problem with logging format because it is not working properly. Our binary log file can not be converted into other format because it will have no info in it. We have no clue why is it so. That is why I am asking for help

Ok, sounds like you have some research to do. It’s neither right nor wrong.
Both ardupilot and px4 can be used on Pixhawk boards. The different firmware projects have different capabilities, communities and licenses.
Depending on your specific use case one might have advantages over the other, but you need to judge using your own criteria.
QGroundControl is the primary gcs software for PX4, but also supports ArduPilot. Missionplanner is the primary gcs for ArduPilot, with limited support for PX4.

Thank you very much for your help.
Could you pleas advise me where can I find more informations about this ? Especially about Pixhawk and mentioned softwares ?
I need method how to downgrade firmware but it seems to be impossible to find anywhere. Do you know how to do so ?

If I remember well, downloading logfile from the SD card using mavlink doesn’t work well.

If I need to analyse an sd card logfile, I always take the SD card out, copy the .bin files to the pc and then use MP to analyse. Don’t convert them to .log or tlog. A lot of information gets lost if you do that.

There is a function called DataFlash Logs. There you can select Review a Log and select your bin file.

Works wonderful.

Oh, and by the way, if you want to install a previous version, go to install firmware and down in the right hand corner you see Pick previous firmware. You then get a drop down list where you can choose from.

But how can I get logfile when there is none. When I insert card to PC there is only ulog file format and it is not possible to review in MP. Is there any other tool to analyse this type of format ?
Still thank you very much for your answer.

Ah, OK. Sorry. I was under the impression you were trying to read a bin file as you also posted this question on

I tried, but I cannot find a converter software.

Yes I post it there because we are desperate. We just can not review a log that we get from SDcard. We tried downgrading firmware, different sd cards, nothing works. When we a use ardupilot firmware logging works great.
But it would be better for us to use PX4 flight stack, therefore we need to use “logger on” option. After we download files from pixhawk via “download dataflash logs” we only have some binary file on sd card. When I take it out from pixhawk and then insert to PC there is only ulog file that is not readable and not usable. I saw that there is lot of information in that file but that is some compiled messages or something like that.
Another issue is that when we try to “review a log” it write error that we need FMT messages that are not included and we don’t know how to add them to logging.

All we need is to see data in which position our flaps were during flight and the speed it has and so on . Thats why we want to convert it to matlab.

But still thank you very much for your help.