How can I change QGC to talk english without a "strong" German accent

Hi, I installed QGC 3.2.1 on German OSX Sierra 10.12.6
The Voice Messages sound terrible: English text with a horrible difficult to understand German accent.
I have changed in the system settings Lnaguage and Region to US without any success.
How can fix this that the spoken messages are in a understandable english. (I installed QGC on native english MAC, then QGC sounds fine)
Thanks Jakob

This comes from an OS settings. I’m not sure which one. It does not come from a QGC setting.

I found a way to fix the problem. In the system preferences I had to move english to the top as Primary Language. Selecting only language and region was not sufficinet. After this modification OSX asks for a restart.
Would be great to move the language selection to QGC.
I have the same problem with WIN10 but on WIN I was unable to fix this.