HobbyKing ESC wont initialize with Pixhawk 2

Trying to get a couple HobbyKing ESC’s working with the pixhawk 2 ( https://hobbyking.com/en_us/hobby-king-60a-esc-4a-sbec.html & https://hobbyking.com/en_us/hobby-king-80a-esc-4a-sbec.html )
Both work fine when connected directly to a receiver, however, when connected to the pixhawk 2 and power is applied they only beep 4 times rather than the usual 6 and the motor won’t spin.
Pixhawk still arms fine and everything else works, just no motor spin.
Tried with one of HobbyKings Red Brick ESC’s ( https://hobbyking.com/en_us/hobby-king-80a-esc-4a-sbec.html ) and that worked without issue leading me to think it’s not likely to be an issue with pixhawk setup its self?
Tried calibrating the ESC’s while connected to the pixhawk, wasn’t able to calibrate though. Successfully calibrated them while connected directly to a receiver though that didn’t help. Also reset them to factory default and tried changing their pwm frequency from 8Mhz to 16Mhz to no avail.

Any suggestions? (ESC Manual: https://cdn-global-hk.hobbyking.com/media/file/197963661X25564X0.pdf )