Esc calibration not Working

I have a Pixhawk 2.4.8. I tried to calibrate using it but the ESC never goes into calibration mode(no beeps). I followed the correct procedure of connecting the Power, waiting for 3 color lights then disconnecting and connecting again, but they never calibrate. Then, I tried to calibrate them separately using the Radio controller and I was able to calibrate them but now whenever I turn on the pixhawk motors never move after arming. They just keep beeping. What should I do?

I have the same issue, if I connect the ESCs to my receiver directly, then there is no issue, but when I connect the ESCs to my pixhawk, the ESC that is on Channel1 successfully calibrates, but the 2nd ESC no matter which channel I use, it doesn’t calibrate, it beeps endlessly. I even assigned the channel to throttle on my frsky taranis lite. Still it doesn’t work. See images for wiring connection setup. Please help :sob:

You can refer to Motor/Servo Checks | PX4 User Guide to check the issue Such as

  • If a safety button is used, it must be pressed before motor testing is allowed.