Gazebo SITL Simulation Issue on Mac

Hi Everyone,

I have downloaded the correct gazebo version for my mac along with downloaded the Px4 Repository as stated in the documentation, but when trying to execute a gazebo simulation with the make command: “make px4_sitl gz_rc_cessna”.

I also tried opening the gazebo server in a separate terminal window as stated in the gazebo documentation and no change.

In order to actually get the make command to work without errors, I had to include the entire path name as seen here,“make px4_sitl /Users/DanielleLaptop/Px4/PX4-Autopilot/ROMFS/px4fmu_common/init.d-posix/airframes/4003_gz_rc_cessna”.

I also tried to run the file after a make command like so, “./ROMFS/px4fmu_common/init.d-posix/airframes/4003_gz_rc_cessna” but got a “command not found” error.

I have no idea how to get the gazebo simulation to run properly on my mac. If someone could help me out with more specifics of what to run so the simulation will work, I would greatly appreciate it.

Thanks so much!