Gazebo Scene has no member named ‘GetSimTime’

When trying:
~/src/Firmware$ make posix_sitl_default gazebo_tailsitter

I obtain an error message of:
~/src/Firmware/Tools/sitl_gazebo/src/gazebo_geotagged_images_plugin.cpp:149:38: error: ‘class gazebo::rendering::Scene’ has no member named ‘GetSimTime’
common::Time currentTime = scene_->GetSimTime();
make posix_sitl_default jamvsim works fine.

Have I the wrong version of gazebo?


I suspect that you have Gazebo 8.

We’re supporting 7 officially at the moment.

Thank you so much for your reply Kabir.
I have installed gazebo7, but still get the same error message.
If I type “gazebo” in a terminal the gazebo sim starts and says 7.5 for the version.
How can I ensure all vestiges of gazebo8 have been removed?

Thanks again,


This was of use in removing other installs of gazebo:

But I have removed too much. Now “~/src/Firmware/make posix_sitl_default gazebo_tailsitter” produces:

FAILED: cd /home/adrian/src/Firmware/build_posix_sitl_default/build_gazebo && /usr/bin/cmake --build . && /usr/bin/cmake -E touch /home/adrian/src/Firmware/build_posix_sitl_default/external/Stamp/sitl_gazebo/sitl_gazebo-build
[1/1] Re-running CMake…
– install-prefix: /usr
CMake Error at CMakeLists.txt:26 (find_package):
By not providing “Findgazebo.cmake” in CMAKE_MODULE_PATH this project has
asked CMake to find a package configuration file provided by “gazebo”, but
CMake did not find one.

Could not find a package configuration file provided by “gazebo” with any
of the following names:


Add the installation prefix of “gazebo” to CMAKE_PREFIX_PATH or set
“gazebo_DIR” to a directory containing one of the above files. If “gazebo”
provides a separate development package or SDK, be sure it has been


Ok, this is fine.

Now install libgazebo7-dev, and it should work, assuming you have gazebo7 installed properly.

Thanks again Kabir. After 2 and half days it is working. I had to remove libgazebo7-dev first, then re-install and install the tool chain:


@mhkabir my problem is I am using a mac with Sierra and it seems that gazebo7 is not upward compatible because i am getting an error: *t4-no-webkit: This formula either does not compile or function as expected on macOS versions newer than El Capitan due to an upstream incompatibility.
Error: An unsatisfied requirement failed this build.

which is why i installed gazebo8 but that is not supported at the moment. Is there a workaround ?