External Mpu9250 not recognized

I can’t get my 9250 working. Tried wiring to spi then opened up console nsh and tried starting the sensor with -X and just says no device. Tried this on another sensor I have that has a 9250 and a baro on and same thing (did that with i2c). Tried with just an mpu6000 and it worked so what am I missing here? Ran the sensors through an Arduino to get their default id and showing 0x1e for the 6000. Correct and working. 0x68 and 0x76 for the 9250 and baro. So what do I do or am I doing wrong?

Did you find a fix for that? I am struggling with the same problem.

Same problem. Couldn’t figure it out.

I am writing a driver for external airspeed sensor.
I have written the base code copying from an existing SPI driver. Compiling is successful but every-time when i try to do sen120 start in NSH console, it is showing “no instance started (no device on bus?) ” . What could be the problem.? Wiring and all are perfect since i checked with Oscilloscope.
I can see PX trying to send CS and SCLK, but both these signals fading automatically in a couple of seconds time. And my sensor is also working fine.
Thanks in advancee