Error connecting Pixhawk + Skydroid T10 to QGC

I’m currently using a Pixhawk 2.4.8 with Skydroid T10 telemetry to connect to a GCS. Mission Planner successfully connects with this setup. But QGC doesn’t. If Mission Planner is connected to the setup, opening QGC displays the message.
“Error Binding UDP Port: The address is protected.” I guess that’s because Mission Planner is already using it.

But if I disconnect Mission Planner and then connect QGC, it doesn’t work (although the above message doesn’t appear anymore.) When I try to check the console, the connection is detected, but at the end it displays a message in the log: Skipping existing autoconnect “\\.\COM10”

Any help will be much appreciated.

You could try to manually add the connection in the connections tab?

Thanks @JulianOes . I just did. It only works if I set the baud rate as 57600 in Device Helper and 115200 in QGC or Mission Planner. I’m not sure what causes this anomaly. But yeah, manual connection with these baud rate settings work.

1 Like