Custom Designed Board Issues :MTD driver not initialized

Hello,
I’m new to the PX4 and I have developed the customized Pixracer board myself.
My board doesn’t have the SD Card but it has the FRAM.
But the system is unable to initialize the MTD driver. Can anyone please tell me how to initialize the MTD Driver ? And run the Board without the SD Card.

The Difference between the the board and Pixracer:

  1. FM25V02-G is replaced with FM25W256-G.
    FM25V02-G --have opcode for device id and operating frequency upto 40khz.
    FM25W256-G --doesn’t have opcode for device id and operating frequency upto 20khz.
  2. VBUS and VBUS_VALID not used.
  3. No pullup resistor not used for the replaced FRAM (i.e.FM25W256-G)
  4. SD_CARD not used.
    5.IMU Sensor (MPU_6500), Magnetometer (HMC5983) are used in the board but Magnetometer (HMC5983)is not used in the board(unavilable)

Problems with custom board:

  1. mtd driver not working
    Need : Board doesn’t have SD card so required to use FRAM to save the initialization parameter for the board.

    Attempts: intially, Qground control shows “mtd driver not intialized”, then we run the command “mtd start” from the console
    after that also the mtd driver status wasn’t changed.
    Attempts : to comform that their is no communication issue between FRAM and the mcu, we used the pseudo code only to operate the fram, then it worked well.

    Question 1.1 : How to initialize mtd driver for new FRAM (i.e.FM25W256-G) as it doesn’t have the device ID ?
    Question 1.2 : How to use the FRAM insteed of the sd-card (i.e. change rcS file location from sdcard to FRAM)?
    Question 1.3 : Can we use internal eeprom instead of SD-Card and FRAM ?

  2. Unable to open the telem-2 serial port
    Need: To communicate with the board and request the data using mavlink protocol.

    Attempt 1: In Qground control the required parameter settings to open telem-2 were changed first, then saved
    and finally while reborted to apply the setting, the system doesn’t rebort.

    Attempt 2 : Opened the telem-2 port by running the command “mavlink start -d /dev/ttyS2/ -b 115200 -r 1200 -x” in shell.
    but required to give the command everytime when the power supply turned ON/OFF.

    Attempt 3: Tried to located default parameter setting file ( for telem-2 serial port)in the px4_fmu-v4_default code stack,
    No idea where it’s located (also looked into init.d) .

    Question 2.1 : How to apply the setting and make telem-2 port opend by default?
    Question 2.2 : What is the file location for serial telem-2 port default setting?

Unable to open the telem-2 serial port
Need: To communicate with the board and request the data using mavlink protocol.

@Devraj You can configure the serial port to use TELEM2 with the parameters MAV_*_CONFIG as explained in Serial Port Configuration | PX4 User Guide

Tried to located default parameter setting file ( for telem-2 serial port)in the px4_fmu-v4_default code stack,

rcS is the script that is running on boot to start different modules so you can have a look how to configure your system

Since you are on your custom board the porting guide might help: Flight Controller Porting Guide | PX4 User Guide