Can't start sitl sim "warn [mc_pos_control] invalid setpoints"

Hello all, im trying to begin with px4 + gazebo on ubuntu, i have installed gazebo + ROS , and downloaded the firmware following the instructions given on the website and px4’s YT channel. The sim opens correctly by itself but when i do “make px4_sitl gazebo” i get this warn message and ofcourse, if i do “commander takeoff” it activates the failsafe so it doesn’t even start flying. if i do “make px4_sitl jmavsim” its the same.

Msg] Waiting for master.
[Msg] Connected to gazebo master @ http://127.0.0.1:11345
[Msg] Publicized address: 10.0.2.15
INFO [tone_alarm] home set
WARN [mc_pos_control] invalid setpoints
INFO [tone_alarm] notify negative

Do you find this solution?

hello, i just changed the vehicle multiple times, never knew what happened

@Nicolas_Fuentes Did you find any thing

@ronney05
Nope, sorry. But as i said before i changed the vehicle multiple times and now it works with the DJI F450 airframe… never knew why but it works now

Hello Nicolás, do you remember if before that message, the terminal used to print something like:
INFO [commander] Mission #Y loaded, XX WPs, curr: X ?

hello everyone,
Did any of you gentlemen find out what was the cause and how to get rid of this?
Thanks a lot in advance

I would be also interested to hear that what kind of solutions were found