Can not get boot log from system console on Intel Aero FC flight controller

Dear all.We need to have access to boot log of PX4 running on Nuttx. I can connect to nsh shell via mavlink. But at that time Aero FC is already up and running. For externally connected FC to Intel Aero Board steps are clear. Described at

Recent advice was:

The Nuttx terminal is going to a UART that is not exposed outside of AeroFC.
But you can change the Nuttx terminal from that UART to the telemetry UART, compile and flash a PX4 firmware that you will be able to have access to boot log and Nuttx terminal, you will have to do changes in platforms/nuttx/nuttx-configs/aerofc-v1/nsh/defconfig

According the advice I tried to modify the setup. But without success

I have tried steps below. But without success. I am not sure if my understanding is correct. Could you please suggest next steps?

According Aero Board Manual Telem Port = USART 5
So I am trying to change Nuttx System Console to send output to USART 5 (pin RX,TX)
a) From /Firmware/ROMFS/px4fmu_common/init.d/rcS file I know that at /dev/ttyS03 starts MAVLINK protocol (running trough RX,TX pins of TELEM. Upfront I validated it by running mavlink status from NSH on Aero FC). So I disabled

set MAVLINK_F “-r 1200 -d /dev/ttyS3”

b) after compilation with these parameters mavlink was not functional trough WIFI,USB or TELEM and when I was trying to deploy new compilation by make aerofc-v1_default upload. I have got

Attempting reboot on /dev/ttyS1 with baudrate=460800…

I have recovered from this…by uploading new compilation with set MAVLINK_F “-r 1200 -d /dev/ttyS3” line allowed, to AeroBoard and running root@intel-aero:~# aerofc-v1_default.px4

c) back in platforms/nuttx/nuttx-configs/aerofc-v1/nsh/defconfig i tried to change following parameters in

MTD Device Drivers


After this step. Compilation and flashing new FW. And using screen screen /dev/ttyUSB0 57600 8N1 or with 115200 baudrate I do have only messed up characters on my screen. Can you please suggest how parameters of Memory Technology Device should be chnaged? Also after performing these changes I can not use TELEM RX,TX pins for Mavlink. So I guess the output are not fragments of Mavlink protocol

�$��rG����P����rG�dn� ���rG;�0�)7���9�R��J���C�G9��J���C���� �Q��J��C��;�>i>�G�͜<:�>3 ��4��}�:#=_��ǗC��eB�}�J���C�
�� Q9��G_dҋ�$�����������������������dZ6�����$��G����BlJ���C?� Q�+�
i��Grc<�]>�N �@-,��VJ;�聼9�C��eB��VWARN [load_mon] tap_esc low on stack! (292 bytes left)
Q �J���C��.�