Bricked Pixracer with PiX4

Hi everyone,

After losing communication with the Pixracer module running PX4 in flight, we have unable to access PX4. The flight was tethered, so there was no damage resulting from the comm lost. The pixracer appears to be “semi-bricked” and we observed the following"

  • Pixracer powers up. Pink lights flash for 2 seconds, permanent green led light.
  • Pixracer is recognized by Window when connected under USB, but cannot be access using QGroundControl
  • When attempting to flash a fresh PX4 image, flash returns the following error “Flash failed: Command failed: 0x11(PROTO_FAILED) at address 0x000fc000”
  • When attempting to flash with Antenna Tracker image, flash is successful.
  • Once flashed with Antenna Tracker, Pixracer can be connected to via QGC and MP and streaming/reading of Mavlink messages is possible with readings (e.g., IMU) being reasonable. However, when attempting to flash other firmware instance beyond that point, the process interrupts halfway and re-flashing of Antenna Tracker is necessary in order to re-connect.

We have been unsuccessful at finding answers online. Swapping the Pixracer module requires ~4 hrs of work to unmount / remount the hardware around it.**Before we do that, does anyone have a suggestion as to how we resuscitate PX4 on that Pixracer module over USB?

If this was me, I would try the following:

  • I would download a current or previous version of PX4 and see if you can manually upload and see if it accepts it.
  • If above doesn’t work, Use Mission Planner and see if you can install the ArduPilot firmware.
  • If it loads, go through a basic installation and see if you’re able to go to the Parameters page, change something there, save it then go back and see if it took the change.
  • If the above worked, disconnect the FC, close MP, open QGC then connect FC and see if you can upload PX4 and access all setup params.
  • If any of the above fails, then it might be safe to presume that you have a hardware issue.

Good luck.

Thanks @rollys. We tried everything without further success and ended up replacing the Pixracer.