Using QGC on android... waiting for connection

Using QGC on android. I can not get the app to detect the vehicle. Im using a Samsung Galaxy Tab A 2016. I have used mission maker and tower beta, they do connect to the Vechile but I use GCQ on my Mac osx so would like to use it on my Android as well.

First question: Are you using latest Stable 3.4 version? Second question: How are you communication with the vehicle? WiFi? SiK Radio? …?

Just about to post here, the issue is solved. It turned out to be the tablet itself and how it manages connected usb devices. It had assigned the usb device to another app (tower) so QGC was not able to see it. I deleted the other app and now it works. Perfectly I might add.

It was through a Sik Radio via an OTG cable.

Yeah that’s kind of annoying since it leads to mysterious failures.

hey , im new at this , trying to use my android phone for QGC ,
how do i connect the vehicle to the ground station ?

Using either WiFi or a telemetry radio.

I’ll pick up where he left off with the same issue. Android, q ground control, waiting for vehicle via wifi. Using pixracer and the little piggyback wifi board. Able to connect to wifi but not establish connection in Q ground control.

Thank you,

Turn on LinkManagerLog ( and you should be able to see if QGC is connecting to the WiFi link. It it does connect, but you don’t see a vehicle then you have likely have some hardware setup problem.