Trying to get px4tools to work

Sorry guys, massive n00b question coming up here.

My question is about a specific python error but first I better make sure I’m actually doing everything right.
I have programming experience, but I’m completely new to Python. In hindsight, the information provided by dronecrew on their px4tools github is quite informative, but only if you already know what you’re doing. To a complete python beginner, it means nothing. After a very long time, I figured out the process to get everything working. Can someone please confirm that I did everything right? (windows 10)

  • go to and install Anaconda 3.5

  • open command prompt and type
    conda config --add channels
    conda install px4tools jupyter

  • navigate to the folder where I saved my_log.px4log from the pixhawk SD card and type
    python my_log.px4log > my_log.csv

  • type jupyter notebook

That was all correct, right? I have a .csv with a ton of information and a chrome tab open with a jupyter environment running

So now my actual question.
I opened up the example from the px4tools github

In my jupyter notebook I created a new python notebook [root] and copied the inputs from the above example. It throws this at me:

AttributeError: module ‘px4tools’ has no attribute ‘process_data’

What’s that about?
Thanks for reading if you got this far, thanks in advance for an answer!

Looks fishy to me. I can run the script fine, I use the same call in all my px4tools notebooks.

My guess is there is a problem with your installation of px4tools. Maybe try using pip to install jupyter and px4tools?

I haven’t used conda on windows before; I’m an Ubuntu user. You might have a path / environment issue.

Thanks for your help!
It was a conflict between px4tools and python 3.5. I made a new environment with python 2.7 and it worked fine. Why does the github suggest python 3 if it’s not compatible?

I can’t say, I’m not a member of drone crew. Could be that one of the dependencies may have been installed for a different version of python? Anyway, I’m glad you worked it out!

Please try the new conda-forge packages (see px4tools github page). I use python 3.5 with px4tools regularly.