PX4Firmware on Rapi can't save missions

Rapi 2B + Raspbian Lite + Firmware1.5.5 with modifications that make px4 to run without Navio2 board.
I got “Critical : Mission storage unable to write to MicroSD” from QGC and, actually all params including Airframe were reseted after I run “sudo ./px4 px4.config”. It seems only I have this problem because another person who has done the same hasn’ t seen this.
I haven’ t edited anything about px4 storage. What’ s wrong with me?

Although this has puzzled me for a long time, I have found the answer just now.
I forgot to add “param load” into px4.config.
But “WARN [mavlink] Mission storage: Unable to write to microSD” still appearing in my console.

Hi @SalimTerryLi

You should probably open an issue on github. My first guess would be it’s trying to write to a path that doesn’t make sense for your setup, but I’ve never tried PX4 on a raspberry pi.

I finally fixed it. The problem was simply caused by a forgotten line “dataman start” in px4.config .