Pixhawk 4 and PX4 v1.7.3 on Ubuntu 18.04

#1

Hello everyone,

New (excited) member here.
I am expecting to receive my Pixhawk 4 (Beta) tomorrow and preparing to build the firmware (mainly to get to know the codebase atm).

When reading the README.md on github I noticed Pixhawk 4 is not yet mentioned. I suppose this is on the Todo list and that it should work. Or am I looking in the wrong branch?
Am I on the right track when trying to build the firmware on Ubuntu 18.04?

Hoping to have some fun very soon. I will detail my findings on building the firmware here.

Best regards,
Yuri

1 Like
#2

Hello,

If you have an Holybro Pixhawk 4 it’s mentioned here : https://dev.px4.io/en/debug/reference-design.html with FMUv5.

The standar Linux developpement OS is 16.04, I have never tried with 18.04 but I think it must work.

Vivien

#3

Yuri, I can confirm under ubuntu 16.04 you can build a 1.8.beta from Github wich runs. I have not built 1.7.3 for PH4.
jakob

#4

Ok, thank you Vivien and Jakob,.
As expected I received the Holybro Pixhawk 4 today! I’ll start playing around with it.

#5

I try to compile too under 18.04 the only problem I got is when compiling FastRTSP
enjoy

#6

Hi proff,

I saw in New onboard and ubuntu 18.04 install that you have the same issue as I encountered regarding FastRTSP.

I might have found a solution…
http://en.cppreference.com/w/cpp/utility/functional/function

Edit eProsima_FastRTPS-1.5.0-Linux/include/fastrtps/rtps/writer/RTPSWriter.h
Add another include :
#include <functional>

Save the file and build again :

cd eProsima_FastRTPS-1.5.0-Linux; ./configure --libdir=/usr/lib; make -j$cpucores; sudo make install

Can you try this please?
The build seems to work for me afterwards, but I don’t know how to test it yet… I am still getting up to speed with PX4…

Regards,
Yuri

#7

sory yuri for late reply
I will try the fix yuor proposed soon
for now I’m working only with gazebo and sitl and it work’s great under 18.04
but I’ll soon switch on hitl and try to comunicate with ros so I will need fastrtps thank’s a lot for your help

1 Like
#8

In the mean time I succeeded in running HITL with jmavsim and it is working! (running the latest beta2 build of the 1.8.0 firmware)
I am able to control the simulation in jmavsim through the pixhawk 4 fmuv5 with my RC.
Nice to end a day like this.
Next thing to do is getting more telemetry data out of the system and maybe do a real test flight…
Oh yes, and trying java 10 (to check if the update concerning vecmath is released)

1 Like
#9

than’ks yuri !!! I finally got time to test the fix your find and I’m happy !!
it compile !!!
next sterp for me testing mavros and HITL
let’s go … than’ks a lot

1 Like
#10

I have tried to make px4fmu-v4_default
Firmware and have got an errors:

…/…/src/drivers/barometer/bmp280/bmp280_i2c.cpp: In constructor ‘BMP280_I2C::BMP280_I2C(uint8_t, uint8_t, bool)’:
…/…/src/drivers/barometer/bmp280/bmp280_i2c.cpp:74:66: error: declaration of ‘external’ shadows a member of ‘this’ [-Werror=shadow]
BMP280_I2C::BMP280_I2C(uint8_t bus, uint8_t device, bool external) :
^
compilation terminated due to -Wfatal-errors.
cc1plus: all warnings being treated as errors
[334/1007] Generating nuttx/fs/libfs.a
ninja: build stopped: subcommand failed.
Makefile:154: recipe for target ‘px4fmu-v4_default’ failed
make: *** [px4fmu-v4_default] Error 1