Lidar fault issue

I’m working on LPE with flow and lidar
and my lidar has a problem it keep shows
“lidar fault, beta” message
yes it seems quite noisy through QGC analyze like ± 4cm
but I don`t know why
it is connected through PWM
I’ve tested again with new lidar module to find out current module is broken but it is also noisy too
I also checked wire connection

my flow works crazy with this faulty lidar data
can I get some help?

In what environment are you using the lidar? What device are you using? Can you share a log?

I use pixhawk for FCU

I can’t find that log, but there was no distance sensor logged as I remember. It was empty

last week I tried lidar+px4flow on APM stack and it worked pretty nice

which means it is not an H/W issue

but APM doesn’t support mavros local_set_point command with no GPS as far as I tried

so I’m keep I’m working on LPE anyway.

may be trying through I2C would help?

If you have no distance data in the log, the lidar is not actually running. But then you would also not get “lidar fault” messages. Can you do a test to reproduce your problem and share a log?