Installing PX4 on Ubuntu 24.04 x64 VM

I am trying to get PX4 to run on a 64-bit VM with Ubuntu 24.04. I got some problems running the ubuntu.sh configuration script. I could fix most of them, but I reached an impasse with libncurses5. The newest version of that seems to require an older version of libtinfo6. Here is the specific error I’m getting:

The following packages have unmet dependencies:
libncurses5-dev : Depends: libtinfo6 (= 6.2-Oubuntu2.1) but 6.4+20240113-1ubunt
u2 is to be installed
Depends: libncurses-dev (= 6.2-Oubuntu2.1) but 6.4+20240113-1
ubuntu2 is to be installed
libncursesw5-dev : Depends: libtinfo6 (= 6.2-Oubuntu2.1) but 6.4+20240113-1ubun
tu2 is to be installed
Depends: libncurses-dev (= 6.2-Oubuntu2.1) but 6.4+20240113-
1ubuntu2 is to be installed
E: Unable to correct problems, you have held broken packages.

I manually installed the 6.2-0ubuntu2.1 version of libtinfo6, but that didn’t solve the problem.

Should I try on an older version of Ubuntu?

I don’t know whether Ubuntu 24.04 is supported yet. If you use 22.04 it should be fine.

Thanks Julian. I will try v22.004.