Hereflow sensor with UAVCAN not responding

Hi!

We have a HEX Hereflow optical flow sensor(http://www.proficnc.com/all-products/185-pixhawk2-suite.html), but it does not work on our Pixhawk4Mini. Acording to this https://github.com/PX4/px4_user_guide/pull/559 page, the support Hereflow should be implemented.

We think there might be (one of) two issues:

  1. We have not set up the parameters for the autopilot correctly.
  2. Some of the hardware may be broken.

Potential problem 1:
The guide here https://github.com/PX4/px4_user_guide/blob/c03a25be2724e5d89e9ece47425423d5cd100a1d/en/sensor/pmw3901.md indicates that support for the sensor is implemented, but the documentation is not done. We have tried to connect it and configure the parameters at best guess, but we can’t get any readings from it.

Do you know which parameters we should set to make the autopilot use the sensor or how to debug the setup?

Potential problem 2:
When we run uavcan status in the nsh shell the autopilot crashes and reboots. The last thing we see is:


Notice that the HW errors and the IO errors. Is seems to crash when we read the RX for our bus. To me, this seems like either we have a hardware problem, or that perhaps the firmware have a bug.

We tried loading the Pixhawk4Mini with Arducopter 4.0.0, and there we was able to get readings from the distance sensor, but not any optical flow information.

Both the Pixhawk and the Hereflow is new and barely used.

Would you happen to know how to debug this, or what to try?

Related posts:
Hereflow optical flow sensor support claims that the sensor works, but not the distance sensor.

Any help would be greatly appreciated :slight_smile: